| 리포트 | 기술문서 | 테크-블로그 | 글로벌 블로그 | 원샷 갤러리 | 통신 방송 통계  | 한국 ICT 기업 총람 |

제품 검색

| 네트워크/통신 뉴스 | 기술자료실 | 자유게시판 |  
 
 
섹션 5G 4G LTE C-RAN/Fronthaul Gigabit Internet IPTV/UHD IoT SDN/NFV Wi-Fi Video Streaming KT SK Telecom LG U+ OTT Network Protocol CDN YouTube Data Center
 
스폰서채널 |

 

  스폰서채널 서비스란?
Ethernet Bridging 및 Link Aggregation 기초
Basic Understanding of the Ethernet Bridging and Link Aggregation
By Netmanias (tech@netmanias.com)
코멘트 (0)
17

Thank you for visiting Netmanias! Please leave your comment if you have a question or suggestion.
Transcript
EthernetBridging & Link Aggregation 기초
2003년8월11일
NMC Consulting Group(tech@netmanias.com)

2
Ethernet Bridging

3
옛날Repeater .공유허브(Shared Hub)
Repeater 환경에서의Ethernet frame 전달

4
옛날Repeater .공유허브(Shared Hub)
Repeater 환경에서의Ethernet frame 전달(계속)

5
옛날Repeater .공유허브(Shared Hub)
Repeater의 포트 수 이상의 더 많은 단말을 연결하려면
Repeater들을 Cross-over cable을 이용해 연결
연결된 Repeater들 전체가 하나의 collision domain을 형성함
Repeater를 여럿 연결할수록 collision 발생 확률이 증가
Throughput, Transmission delay가 급속히 증가
망 성능의 저하
Repeater를 여럿 collision 확률 증
.Throughput, Transmission delay 급속히증 .망   저

6
MAC-Bridge

7
MAC Bridge의원리(1/3)
Bridging Learning
①각     신 Ethernet Frame Source MAC 주소를기 함.

8
MAC Bridge의원리(2/3)
Backward Learning
이후에 수신된 Frame의 목적지 MAC 주소가 “MAC 주소 Table”에 있으면 그 주소가 배워졌던 포트로 Frame을 전송.

9
MAC Bridge의원리(3/3)
Backward Learning
목적지 MAC 주소가 Frame을 수신한 포트와 같은 경우에는 Forwarding을 하지 않음.

10
Bridged LAN
Bridged LAN: Bridge에 의해 연결된 하나의 Broadcast domain

11
Broadcast Domain (1/2)
두 개의 Bridged LAN = 두 개의 Broadcast domain.

12
Broadcast Domain (2/2)
하나의 Bridged LAN = 하나의 Broadcast domain.

13
Ethernet Switch
Bridge = “Software Repeater”
Switch = “Hardware Bridge”
범용 CPU에 의해 MAC Learning과 MAC Table Search, Frame Forwarding이 이루어짐.
전용 ASIC에 의해  MAC Learning과 MAC Table Search, Frame Forwarding이 이루어짐.

14
Ethernet Switch
Full Duplex Ethernet:.Collision   .
Full Duplex Ethernet:
Collision이 없다.
송수신 (Rx & Tx) 동시에 할 수 있다.

15
MAC Learning Example (1)
Source MAC 주소 A를 배움
Destination MAC 주소가 Unknown이므로, 모든 포트로 Flooding

16
MAC Learning Example (2)
Source MAC 주소 B를 배움
MAC 주소 A가 1번 포트에 있으므로, 1번 포트로만 Forwarding 함

17
MAC Learning Example (3)
Source MAC 주소 C를 배움
MAC 주소 B가 4번 포트에 있으므로, 4번 포트로만 Forwarding 함

18
Bridged LAN의취약점
Loop가 형성되면 Frame이 Loop 내에서 맴돌게 된다.  STP 필요

19
Link Aggregation

20
Link Aggregation이란?
Link Aggregation
여러 개의 Ethernet Port들을 하나의 논리적인 포트로 동작시킴으로써 용량이 큰 이더넷 포트를 구현하게 해주는 기술
Multi-port Trunking 또는 EtherChannel(Cisco)이라고도 한다.

21
Link Aggregation의효과
100Mbps 또는 1Gbps로 제한되어 있는 개별 링크의 용량의 한계를 극복할 수 있다.
스위치 간의 연결, 또는 대용량 서버와 스위치 간의 연결의 경우 100Mbps와 1Gbps 사이의 중간 용량을 구현할 수 있다.
   예) 4포트 → 400Mbps, 8포트 → 800Mbps, …
장애발생 시 링크의 단절을 피할 수 있다.
포트 그룹에 속한 Link 중 어느 하나가 단절되더라도, 동일한 포트 그룹에 속한 나머지 Link가 무사하다면 해당 “논리포트”는 단절없이 계속 서비스가 지속될 수 있다.

22
Load Balancing
Port Group에 속하는 각각의 실제 포트(physical port)에 트래픽이 전달되는 방법 : Load Balancing
트래픽 분산 시 유의사항
가능한 한 모든 링크에 골고루 트래픽이 분산되어야 함
상위 프로토콜의 특성에 따라 동일 Flow에 속하는 패킷들의 순서가 지켜지지 않으면 문제가 발생할 수 있다.
같은 Flow에 속하는 패킷들은 항상 같은 physical port로 전달되어야 한다.

23
Load Balancing 방법
Ethernet Frame의 MAC 주소값에 대해 Hash함수를 적용해 출력에 사용될 physical port를 결정한다.
Source MAC 또는 Destination MAC 주소에 대해 hash 함수를 적용할 수 있다.
(또는 MAC 주소 이외에 IP header(IP address), TCP/UDP header(Port #)의 필드를 hash 함수에 적용하는 스위치도 있다)

24
Link Aggregation 설정
Catalyst3550에서의 Link-aggregation 설정 절차
configure terminal
interface interface-id
switchport mode {access | trunk}
switchport access vlan vlan_id           ; access mode로 설정한 경우에만 해당됨
channel-group channel-group-number mode {auto [non-silent]|desirable [non-silent]|on}
end
show running-config

25
Link Aggregation 설정
Switch_02#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch_02(config)#interface range fa0/5 -8
Switch_02(config-if-range)#switchporttrunk encapdot1q
Switch_02(config-if-range)#switchportmode trunk
Switch_02(config-if-range)#channel-group 1  mode on
Creating a port-channel interface Port-channel1
Switch_02(config-if-range)#end
Switch_02#
04:07:00: %SYS-5-CONFIG_I: Configured from console by console
Switch_02#
Catalyst3550   Link-aggregation (Port-channel) 설정화

26
Link Aggregation 설정
Switch_02#sh running-config
Building configuration...
(중략)
!
interface Port-channel1
no ipaddress
!
(중략)
interface FastEthernet0/5
switchporttrunk encapsulation dot1q
switchportmode trunk
no ipaddress
channel-group 1 mode on
!
interface FastEthernet0/6
switchporttrunk encapsulation dot1q
switchportmode trunk
no ipaddress
channel-group 1 mode on
!
Port Channel Configuration 확인

27
Link Aggregation 설정
interface FastEthernet0/7switchporttrunk encapsulation dot1qswitchportmode trunkno ipaddresschannel-group 1 mode on!interface FastEthernet0/8switchporttrunk encapsulation dot1qswitchportmode trunkno ipaddresschannel-group 1 mode on!(   략)
Port Channel Configuration 확인(계속)

28
End of Document
Related Contents
12/30/2011
Netmanias Blog
12/29/2011
Netmanias Blog
12/28/2011
Netmanias Blog
02/10/2010
Netmanias Technical Documents
11/12/2004
Netmanias Technical Documents

 

 

     
         
     

 

     
     

넷매니아즈 회원 가입 하기

2019년 1월 현재 넷매니아즈 회원은 49,000+분입니다.

 

넷매니아즈 회원 가입을 하시면,

► 넷매니아즈 신규 컨텐츠 발행 소식 등의 정보를

   이메일 뉴스레터로 발송해드립니다.

► 넷매니아즈의 모든 컨텐츠를 pdf 파일로 다운로드

   받으실 수 있습니다. 

     
     

 

     
         
     

 

 

비밀번호 확인
코멘트 작성시 등록하신 비밀번호를 입력하여주세요.
비밀번호