| 리포트 | 기술문서 | 테크-블로그 | 글로벌 블로그 | 원샷 갤러리 | 통신 방송 통계  | 한국 ICT 기업 총람 |

제품 검색

| 네트워크/통신 뉴스 | 기술자료실 | 자유게시판 |  
 
 
섹션 5G 4G LTE C-RAN/Fronthaul Gigabit Internet IPTV/UHD IoT SDN/NFV Wi-Fi Video Streaming KT SK Telecom LG U+ OTT Network Protocol CDN YouTube Data Center
 
스폰서채널 |

 

  스폰서채널 서비스란?
IP QoS 실습 교재
IP QoS In-Class Demonstration
By Netmanias (tech@netmanias.com)
banner
코멘트 (0)
11

Related Video
Thank you for visiting Netmanias! Please leave your comment if you have a question or suggestion.
Transcript
Netmanias 기술문서: IP QoS실습교재

IP QoS실습교재
2004년1월10일

2
.IP QoS Review
.Rate Limiting
.Rate Shaping
.RED/ WRED
목차

3
IP QoS Review

4
Classification
Metering/
Dropper
Marking
-Queue/Schedule
-Congestion
Control (WRED)
-Shaper
QoS Actions at Ingress
QoS Actions at Egress
Identify packet groupsand label using DSCPor CoS
Rewrite CoS/DSCP
SP & WFQ queues/port-WRR Scheduling-Strict Priority SchedulingWRED for congestionTraffic Shaping
Dropped
Pkt
Pkt
Pkt
Out of profile
Rate-Limiting(Policing)
WFQ
SP
DiffservQoS Model

5
Packet Classification & Marking
.Classified based on
.TCP/UDP Port
.All/any IP traffic
.Layer 3 DSCP or IP precedence value
.IEEE 802.1p CoS value
.Source/Destination MAC address
.Incoming/outgoing interface
.Marking
.IP DSCP value for Layer 3
.IP Precedence value for Layer 3
.CoS value for Layer 2

6
Shaping
Traffic
Time
Traffic Rate
Traffic
Time
Traffic Rate
Policing
Traffic
Time
Traffic Rate
Traffic
Time
Traffic Rate
Steady State
Behavior
Transient
Behavior
Policing versus Shaping

7
Policer vs Shaper
.Policer
.in both incoming and outgoing directions.
.Out-of-profile packets are dropped
.Causes TCP retransmits
.Shaper
.in outgoing direction only
.Out-of-profile packets are queued
.Minimizes TCP retransmits

8
Congestion Avoidance .RED/WRED
.When output queue(at egress) is full
.input traffic > output port bandwidth
.By default, routers/switches perform tail dropping
.Tail Drop cause TCP global synchronization
.Inefficient link usage at congestion point

9
Slow Start
Exponential Growth
Congestion Avoidance Phase
Linear Growth
TCP Slow Start

10
TCP Global Synchronization
.Multiple TCP session start at different
.TCP window sizes(Cwnd) are increased
.Because of tail drop, many TCP sessions temporarily slows down to the extreme
.Then all TCP flows slow-start again .TCP global synchronization
Cwnd (RTT)
Time
Tail Drop
3 Traffic Flows Start at Different Times
Another Traffic Flow
Starts at This Point

11
RED Operations
.RED drops packets randomly before queue reaches full
.TCP session with significant cause of congestion will be dropped with a higher statistical probability
.Random drop cause TCP sessions to reduce window sizes
.RED result :
.much less TCP global synchronization
.TCP can use bandwidth more efficiently
AverageQueueSize
DropProbability
Min Threshold
Max Threshold
Max Queue
Length (Tail Drop)
No Drop
Random Drop
Tail Drop

12
WRED (Weighted Random Early Detection)
AverageQueueSize
DropProbability
Min 1
Max 1
Min 3
Min 2
Max 2
Max 3
Max Queue
Length (Tail Drop)
.Use a different RED profile for weight
.Weight :
.IP Precedence (8 profiles)
.DSCP (64 profiles)
1 / mark-prob-denominator

13
Rate Limiting

14
cloud
Catalyst6500SR
catalyst
ATMswitchrouter
ISP Backbone
Dynamic Route
100FX
100FX
catalyst
L2
pc
pc
10/100
UNI
catalyst
L2
pc
pc
10/100
UNI
catalyst
L2pc
pc
10/100
UNI
catalyst
L2
pc
pc
10/100
UNI
catalyst
L3
L3
Port-based
VLAN
L3
Static route
(default gateway)
100FX
Static route
(default gateway)
210.10.12.0/26(CIDR)
210.10.13.0/26 (CIDR)
Rate-limiting: 10Mbps
100FX/GbE
Internet Cafe Configuration

15
Per-Port Rate-Limiting(Policing)
Policing (Dropping)
Output Link (Uplink)
Input Link (Downlink)
FlowQueue
.Service 측면
.가입자별(FE Port별)로임의의Rate을보장/제한해줄수있음.
.문제점
.TCP flow에대해Rate-limiting을적용하는경우, TCP flow control
mechanism으로인해Retransmission과Slow start의영향으로TCP
session의Throughput에현저한저하가발생함.
Traffic Arrival Rate
10Mbps
Drop Packet !!
Bandwidth
Time

16
.Congestion 이발생하면Cwnd = 1
.Threshold 이후에는Cwnd 가‘1’씩증가
.Fast Retransmission and Fast Recovery Algorithm
1 Packet
Cwnd = 1
Cwnd = 2
Cwnd = 8
2 Packets
Cwnd = 1Threshold = 8(16/2)
4 Packets
8 Packets
Cwnd = 4
1 Packet
Time-Out or 3 duplicated ACKs
16 Packets
2 Packets
4 Packets
8 Packets
9 Packets
TCP Slow-Start (Congestion-Avoidance)

17
Congestion Avoidance PhaseLinear Growth
RTT
Cwnd
Slow Start
Exponential Growth
Bulk-Transfer TCP Session

18
.TCP Throughput .
.MSS = 1460 bytes, RTT = 70ms 인경우,
.Packet Loss = 1 / 100,000 (99.999 %) .TCP throughput . 37 Mbps
.사용자의물리적연결속도는100Mbps 이지만, TCP 성능은37Mbps
MSS
Loss
RTT
0.7
TCP Performance

19
Demo Configuration
catalyst
pc
Catalyst6500SR
L3 Switch(Cisco 3550)
FTP Server
L2 Switch
1000LX100Tx (100Fx)
Rate Limiting
.Chariot 를사용한TCP / UDP Throughput 확인
.TTP 서버를사용한실제TCP Throughput 확인
L3 Switch(RS 3000)
inventory
catalyst
10.10.10.1(gi.3.1)
210.16.2.1(et.1.1)
10.10.10.2 (gi 0/1)
210.16.1.1 (fa 0/1)
210.16.1.10
210.16.2.10
TCP Traffic
Tail-Drop

20
Rate Limiting 시험망구성
pc
j0285750
Client
FTP Server
Dasan 1124
Cisco 3550
RS3000
ingress traffic drop
GE21

System Configuration(1/2)
.RS3000 configuration
rs#configure
rs(config)#negate all
rs(config)#interface create ip C3550 address-netmask 10.10.10.1/24 port gi.3.1 up
rs(config)#interface create ip FTP address-netmask 210.16.2.1/24 port et.1.1 up
rs(config)#ip add route default gateway 10.10.10.2
rs(config)#exit
.Cisco 3550 QoS configuration
Switch(config)#mls qos

1. aggregate-policer 를정의한다.여기서적용할려구하는rate-limiting의범위를정의
// rate-limiting: 10Mbps, Burst size: 16000
Switch(config)# mls qos aggregate-policer rate_limit 10000000 16000 exceed-action drop

2. access-list를정의합니다.여기서rate-limiting을적용하려구하는traffic flow 를정의
Switch(config)#access-list 1 permit any// 모든traffic을permit 하는access-list id 1 을생성합니다.

3. policing 을적용할traffic class 를정의합니다.
access-list id 1 을match
Switch(config)#class-map match-all all_traffic
Switch(config-cmap)#match access-group 1// access-list id 1 을match
Switch(config-cmap)#exit

4. 이제드디어지금까지작성한traffic class 와aggregator-policer 를적용합니다.
Switch(config)#policy-map rate_test
Switch(config-pmap)#class all_traffic
Switch(config-pmap-c)#police aggregate rate_limit
Switch(config-pmap-c)#exit
Switch(config-pmap)#exit5.
지금까지작성한QoS policy 를interface에적용합니다.
Switch(config)#interface fastethernet 0/1Switch(config-if)#service-policy input rate_test

22
System Configuration(2/2)
.Cisco 3550 interface configuration
Switch#conf t
Switch(config)#interface GigabitEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.10.10.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface FastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 210.16.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.1// set default gateway
Switch(config)#ip routing

23
Rate Shaping

24
cloud
Catalyst6500SR
catalyst
ATMswitchrouter
ISP Backbone
Dynamic Route
100FX
catalyst
L2
pc
pc
10/100
UNI
catalyst
L2
pc
pc
10/100
UNI
catalyst
L3
pc
pc
10/100
UNI
catalyst
L3
pc
pc
10/100
UNI
L3
Port-based
VLAN
L3
Static route (default gateway)
100FX
Static route (default gateway)
210.10.12.0/26(CIDR)
210.10.13.0/26 (CIDR)
Rate-Shaping: 10Mbps
GbE
catalyst
L2
catalyst
100FX
Cafe
MTU
L2
catalyst
L3
100FX/GbE
Internet Cafe Enterprise Configuration

25
Per-Port Rate-Shaping
Classification
Metering
Marking
f1
Flow
Queue
rf1
Output Link(Uplink)
Input Link (Downlink)
Queue mgt (WRED)
Rate shaping
계약한대역폭10Mbps
Traffic Arrival Rate
Traffic Service Rate
Shaping (Delayed and Confirmed), not dropping!
10Mbps
Arrival
Queued
NWC service(shaping)
.Service 측면
.가입자별(FE Port별)로임의의Rate을보장/제한해줄수있음.
.Rate-shaping: 즉각적인폐기가아니라버퍼링후에협상된Rate으로망으로/가입자측으로젂달해줌
.TCP Throughput 저하문제해결됨. 현재대부분의벤더들이Rate-shaping 기능을지원하고있음.
Bandwidth
Time

26
Demo Configuration
catalyst
pc
Catalyst6500SR
L3 Switch(Dasan 5124F)
FTP Server
L2 Switch
1000LX
100Tx (100Fx)
Rate Shapping
.Chariot 를사용한TCP Throughput 확인
.FTP 서버를사용한실제TCP Throughput 확인
L3 Switch(RS 3000)inventory
catalyst
10.10.10.1(gi.3.1)
210.16.2.1(et.1.1)
10.10.10.2 (gi 0/1)
210.16.1.1 (fa 0/1)
210.16.1.10
210.16.2.10
TCP Traffic
Buffering & NWC Scheduling
Queued
NWC

27
Rate Shaping 시험망구성도pc
j0285750
Client
FTP Server
Dasan 1124
Dasan 5124F
RS3000
100Base-Fx
GbE
Ingress & Egress
traffic shapping

28
System Configuration
.5124F Configuration (Interface)
SWITCH#
SWITCH#conf t
SWITCH(config)#restore factory-defaults
SWITCH(config)#exit
SWITCH#reload
SWITCH#conf t
SWITCH(config)#bridge
SWITCH(bridge)#set vlan create br5 5
SWITCH(bridge)#set vlan create br25 25
SWITCH(bridge)#set vlan pvid 5 5
SWITCH(bridge)#set vlan pvid 25 25
SWITCH(bridge)#set vlan del br1 5,25
SWITCH(bridge)#set vlan add br5 5 u
SWITCH(bridge)#set vlan add br25 25 u
SWITCH(bridge)#exit
SWITCH(config)#interface br5
SWITCH(config-if)#ip address 210.16.1.1/24
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#interface br25
SWITCH(config-if)#ip address 10.10.10.2/24
SWITCH(config-if)#no shutdown
SWITCH(config-if)#exit
SWITCH(config)#ip route 0.0.0.0/0 10.10.10.1

.5124F Configuration (Rate Shaping)
SWITCH(config)#bridge
SWITCH(bridge)#set rate 5 10// port 5, 10Mbps (ingress & egress)

.RS3000 Configuration
rs#configure
rs(config)#negate all
rs(config)#interface create ip 5124F address-netmask 10.10.10.1/24 port gi.3.1 up
rs(config)#interface create ip FTP address-netmask 210.16.2.1/24 port et.1.1 up
rs(config)#ip add route default gateway 10.10.10.2
rs(config)#exit

29
RED/WRED
30
Demo Configuration .RED/WRED
pc
100Tx
Ingress RED/WRED
inventory
FTP Server
Packet Generator(IXIA)
WRED
Flow
Queue
et.1.10
et.2.1
et.1.1
WRED
Flow
Queue
WRED
Flow
Queue
catalyst
210.16.1.10
210.16.1.30
210.16.1.40
L2/L3 Switch (RS3000)
210.16.1.20
Traffic Generation(100Mbps)
.Chariot 를사용한TCP Throughput 확인
.FTP 서버를사용한실제TCP Throughput 확인

31
RED/WRED 시험망구성도
pc
Client
FTP Server
RS3000
Packet Generator(IXIA)
210.16.1.10
210.16.1.40
210.16.1.30
L2 Switch
100Mbps
Destination IP: 210.16.1.40
inventory 210.16.1.20

32
RED/WRED Parameters
TH_MIN 25%
TH_MAX 50%
Pmax
Low
1
0
Drop
Probability
Min
Max
Max Queue
Length (Tail Drop)
.Case 1
TH_MIN
25
TH_MAX
50
Pmax
High
.Case 2
1
0
Drop
Probability
Min
Max
Max Queue
Length (Tail Drop)
Pmax
Pmax
(Mark-prob-denominator : 2)
(Mark-prob-denominator : 7)

33
System Configuration
.RS3000 Configuration (Case 0) .No RED/WRED
.RS3000 Configuration (Case 1) .경사완만

rs#configure
rs(config)#negate all
rs(config)#qos wred input exponential-weighting-constant 3 mark-prob-denominator 7min-queue-threshold 25 max-queue-threshold 50 port et.1.1 queue low
rs(config)#exit

.RS3000 Configuration (Case 2) .경사급격
rs#configure
rs(config)#negate all
rs(config)#qos wred input exponential-weighting-constant 3 mark-prob-denominator 3min-queue-threshold 25 max-queue-threshold 50 port et.1.1 queue low
rs(config)#exit

34
Consideration
.Without RED/WRED
.FTP Throughput
.With RED/WRED
.FTP Throughput
.Parameter 가결과에비친영향은?

35
End of Document
Related Contents
01/13/2012
Netmanias Blog
01/06/2012
Netmanias Blog
12/30/2011
Netmanias Blog
05/23/2006
Netmanias Technical Documents
02/18/2006
Netmanias Technical Documents
11/20/2005
Netmanias Technical Documents
12/10/2003
Netmanias Technical Documents

 

 

     
         
     

 

     
     

넷매니아즈 회원 가입 하기

2020년 1월 현재 넷매니아즈 회원은 49,000+분입니다.

 

넷매니아즈 회원 가입을 하시면,

► 넷매니아즈 신규 컨텐츠 발행 소식 등의 정보를

   이메일 뉴스레터로 발송해드립니다.

► 넷매니아즈의 모든 컨텐츠를 pdf 파일로 다운로드

   받으실 수 있습니다. 

     
     

 

     
         
     

 

 

비밀번호 확인
코멘트 작성시 등록하신 비밀번호를 입력하여주세요.
비밀번호