| 리포트 | 기술문서 | 테크-블로그 | 글로벌 블로그 | 원샷 갤러리 | 통신 방송 통계  | 한국 ICT 기업 총람 |

제품 검색

| 네트워크/통신 뉴스 | 기술자료실 | 자유게시판 |  
 
 
섹션 5G 4G LTE C-RAN/Fronthaul Gigabit Internet IPTV/UHD IoT SDN/NFV Wi-Fi Video Streaming KT SK Telecom LG U+ OTT Network Protocol CDN YouTube Data Center
 
스폰서채널 |

 

  스폰서채널 서비스란?
Switching & Routing 실습 교재
Switching & Routing In-Class Demonstration
By Netmanias (tech@netmanias.com)
banner
코멘트 (0)
11

Thank you for visiting Netmanias! Please leave your comment if you have a question or suggestion.
Transcript
Netmanias 기술문서: Switching & Routing 실습교재

Switching & Routing 실습교재
2007년5월11일
NMC Consulting Group(tech@netmanias.com)

2
Table of Content
.Layer 1
.Cable
.Layer 2
.Port Mirroring
.Bridging Port
.VLAN Setup
.Trunk Port
.Tagged VLAN
.LAG
.MAC Table
.STP (L2 Loop Free)
.Layer 3
.L3 Interface/Static Route
.Default Route
.ECMP
.Metric (Link Cost)
.OSPF/Admin Distance
.Network Convergence with OSPF
.ICMP
.ARP
.TraceRoute
.DHCP/DNS

3
Overview
Layer1
Layer2
Misc
To help network beginners cope with experiments about what they learned by themselves
.UTP Cable
.Straight Cable
.Cross Cable
.SFP
.GBIC
.Auto Negotiation
.Speed
.Duplex
.Flow-Control
.L3 Interface
.Connected
.Sub-Interface
.Static Route
.Default Route
.Null Routing
.Link Cost (Metric)
.Routing Table
.Admin Distance
.ECMP
.OSPF
.Network Convergence
.ARP
.ARP Table
.ICMP
.PING
.Unreachable
.MGMT
.Traceroute
.Ping
.DHCP
.DNS
.HSRP
Layer3
Purpose
.Debugging Skill
.Chariot
.iPerf
.Console Program
.Baudrate
.SmartBits
.Smart Window
.TRT
.N2X
.Case Study
.Documentation
.Test Report
.Port Mirroring
.Wireshark
.Filter
.Bridging Port
.VLAN Setup
.Tagged VLAN
.Untagged VLAN
.Trunking
.LAG
.Ether-Channel
.Static-Channel
.MAC Table
.STP
.L2 Loop Free

4
Cable
Prerequisites
UTP Cables, RJ45 Jack, LAN Tool, Ripper, Cutter
cable_utp_clip_image002
image013
Crossover Cable
RJ-45 PIN
RJ-45 PIN
1 Rx+
3 Tx+
2 Rc-
6 Tx-
3 Tx+
1 Rc+
6 Tx-
2 Rc-
Straight-through Cable
RJ-45 PIN
RJ-45 PIN
1 Tx+
1 Rc+
2 Tx-
2 Rc-
3 Rc+
3 Tx+
6 Rc-
6 Tx-
Example of Straight Cable
568A
568B
568B568B
What’s MDI/MDIX?
Challenge
1. Straight-through cable과Cross-over cable을육안으로구분하시오

5
Auto Negotiation
PrerequisitesCisco Catalyst 3500 2EA, UTP Cable (UTP Category-5 Straight/Crossover) 2EA, PC 1EA
Cisco_3560_48
Cisco_3560_48
ez1_38637_0
시안3
Connect Cables
Set Speed 10 at DUT-A
DUT-A
DUT-B
Set Flow-control off at DUT-A
3Set Duplex half at DUT-A
Disable Auto-negotiation at DUT-A
Result
1. What’s the result of auto-negotiation for each case?
Challenge
1. 한쪽은auto-nego, 다른한쪽은100M, Full 고정으로설정했을때의결과는?
a3
Cisco Command
configure terminal
interface interface_id
speed [auto | 100 | 10]
duplex [auto | full | half]
show interfaces status

6
Port Mirroring
PrerequisitesCisco Catalyst 3500 1EA, UTP Cable (UTP Category-5 Straight) 2EA, PC 1EA, SMB200 1EA Cisco_3560_48
ez1_38637_0
시안3
Connect Cables
Connect DUT to
LAN
DUT-A
Start capture with WireShark
Send Packet
Result
1. Write down the configuration of DUT-A for mirroring.
2. Attach screenshot of the captured packets including analysis
a3
Cisco Command
configure terminal
no monitor session {session_number| all | local | remote}
monitor sessionsession_numbersource{interfaceinterface-id| vlanvlan-id} [, | -] [both| rx| tx]
monitor sessionsession_number destination{interfaceinterface-id[, | -] [encapsulation replicate]}
See “Configuring SPAN” in C3560/3750 Config Guide.ez1_38637_0
시안3
LAN
1)ping2) ftp
Configure Mirroring
Mirror dest.
Challenge
1. DUT를실습LAN 환경에연결하시오.
2. Canon printer와연결된PC에FTP server를설치하시오.

7
Bridging Port .VLAN Setup
Prerequisites
Cisco Catalyst 3500 1EA, UTP Cable (UTP Category-5 Straight) 2EA, PC 1EA, SMB200 1EA
Cisco_3560_48
ez1_38637_0
시안3
Connect Cables
Make VLAN 10Add ports to VLAN 10
DUT-A
Capture Packet with Ethereal (WireShark)
Send Packet
What’s PVID?
What’s Access Port?
What’s Trunk Port?
VLAN 10
Result
1. Write down the configuration of DUT-A for VLAN setup
2. Show VLAN Table
3. Show MAC address table
4. Show ARP table of each host
5. Attach screenshot of the captured packet
a3
Cisco Command
configure terminal
vlan vlan_id
exit
interface interface_id
switchport access vlan vlan_id
exit
ez1_38637_0
시안3
Challenge
1. 앞서설정한Mirroring 설정을삭제하시오.
2. VLAN 10 내의두PC는자동으로IP할당을받을수없으므로고정IP 설정할것

8
ez1_38637_0
시안3
Cisco_3560_48
Trunk Port I
Prerequisites
Cisco Catalyst 3500 2EA, UTP Cable (UTP Category-5 Straight) 3EA, PC 1EA, SMB200 1EA
Cisco_3560_48
ez1_38637_0
시안3
Make VLAN 10Add ports to VLAN 10
DUT-A
Start Capture
with WireShark
Send ping (A <-> B)
VLAN 10
Set this port as Trunk Port
Result
1. Write down the configuration of DUT-A for Trunk port.
2. Show VLAN Table
3. Show MAC address table
4. Attach screenshot of the captured packet
Host A
Host B
Mirror dest.
Challenge
1. 802.1Q VLAN tag를보고싶다. Mirror (SPAN) source port를무엇으로지정해야할까?
2. Mirror (SPAN) destination port에서802.1Q encapsulation을그대로받을수있도록설정하시오.a3
Cisco Command
configure terminal
interface interface_id
switchport trunk encapsulation dot1q
switchport mode trunk
exit
Setting a port as Trunk Port

9
Trunk Port II
Prerequisites
Cisco Catalyst 3500 2EA, UTP Cable (UTP Category-5 Straight) 3EA, PC 1EA, SMB200 1EA
Cisco_3560_48
ez1_38637_0
시안3
DUT-A
Start Capture with WireShark
Send Packet-Packet A: Untagged Frame-Packet B: Tagged Frame VLAN10-Packet C: Tagged Frame VLAN20
VLAN 10
Result
1. Write down the configuration of DUT-A for Trunk port.
2. Show VLAN Table
3. Attach screenshot of the captured packet
4. Which packets are captured at PC?
What’s Access Mode VLAN ID (=Native VLAN) of each trunk port?
Cisco_3560_48
Add port to VLAN 10
Set these ports as Trunk Port
Challenge
1. 앞서설정한Mirroring 설정을삭제하시오.
DestMAC = Broadcast
2. Make VLAN 10, 20

10
MAC Table
Prerequisites
Cisco Catalyst 3500 1EA, UTP Cable (UTP Category-5 Straight) 3EA, PC 1EA, SMB200 1EA
Result
1. Write down the configurations of DUT-A and DUT-B for Trunk port respectively.
2. Show VLAN Tables of DUT-A and DUT-B
3. Attach screenshot of the captured packet
4. Which packets are captured at PC?
5. Show MAC address tables of DUT-A and DUT-B respectively
Cisco_3560_48
ez1_38637_0
시안3
DUT-A
Capture with WireShark
Send Packet-Packet A: Untagged Frame-Packet B: Tagged Frame VLAN10-Packet C: Tagged Frame VLAN20
Cisco_3560_48
DestMAC = Broadcast
Make VLAN 10, 20
VLAN Trunk Link
Access Link
VLAN 10
VLAN Trunk Link
VLAN Trunk Link
VLAN Trunk Link
VLAN Trunk Link
VLAN Trunk Link
Access Link
VLAN 20
Challenge
1. 각Switch가Source MAC address learning을할수있도록, PC와SMB port에서각각traffic을발생시킨후“Send Packet” 단계를짂행할것.
a3
Cisco Command
show mac-address-table dynamic

11
LAG
Prerequisites
Cisco Catalyst 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA, SMB200 1EA
DUT-B
Send Packet-Untagged Frame
#NAME?
Set these ports as LAG
DUT-A
Make VLAN 10Add ports to VLAN 10
Add LAG to VLAN 10
Result
1. Write down the configurations of DUT-A and DUT-B for LAG respectively.
2. Show VLAN Tables of DUT-A and DUT-B
3. Show LAG Status of DUT-A and DUT-B
4. Attach screenshot of the captured packet
5. Show MAC address tables of DUT-A and DUT-B respectively
Challenge
1. 각Switch가Source MAC address learning을할수있도록, 각SMB
port에서traffic을발생시킨후“Send Packet” 단계를짂행할것.
2. LAG에속한두포트로골고루traffic이분산될수있도록, 다양한source
MAC, destination MAC address들을사용하여traffic을생성하시오.
a3
Cisco Command
configure terminal
interface interface_id
channel-group 1 mode on
exit
interface port-channel channel-group-number
switchport mode access
switchport access vlan 10
Setting an LAG

12
STP (L2 Loop Free)
Prerequisites
Cisco Catalyst 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA
ez1_38637_0
시안3
Connect cables to form loop topology
DUT-B
VLAN 10
DUT-A
Make VLAN 10Add ports to VLAN 10
Result
1. Write down the configurations of all DUTs for STP configuration respectively.
2. Show VLAN Tables of all DUTs
3. Monitor the status of DUTs after sending packet when STP disabled
4. Monitor the status of DUTs after sending packet when STP enabled
5. Show STP status of all DUTs
DUT-C
VLAN 10
PC1
Disable STP in VLAN 10
PC1 sends Ping to Unknown Host
Enable STP in VLAN 10
PC1 sends Ping to Unknown Host
a3
Cisco Command
spanning-tree vlan vlan_id
no spanning-tree vlan vlan_id
show spanning-tree

13
L3 Interface / Static Route
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 3EA, PC 1EA, SMB200 1EA
ez1_38637_0
시안3
Connecting Cables
1
DUT-B
Capture Packet with Ethereal (WireShark)
-Default Gateway: 10.1.1.254
Send Packet-From 10.1.2.1 to 10.1.1.1-From 10.1.2.1 to 30.1.1.1-From 10.1.2.1 to 40.1.1.1
4
5
DUT-A
2
3
10.1.1.0/24
0.1
0.254
20.1.1.0/30
0.1
0.2
10.1.2.0/24
0.254
0.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.2.0/24
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.1.0/24
Result
1. Write down the configurations of DUT-A and DUT-B for L3 Interface
and Static Routes respectively.
2. Show Interface Status of DUT-A and DUT-B
3. Show Routing Tables of DUT-A and DUT-B
4. Attach screenshot of the captured packet
a3
Cisco Command
configure terminal
ip classless
ip routing
ip subnet-zero
interface interface_id
no switchport
ip address 20.1.1.1 255.255.255.252
no shutdown
exit
ip route 10.1.2.0 255.255.255.0 20.1.1.2

14
Default Route
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 3EA, PC 1EA, SMB200 1EA
ez1_38637_0
시안3
Connecting Cables
1
DUT-B
Capture Packet with Ethereal (WireShark)
-Default Gateway: 10.1.1.254
Send Packet-From 10.1.2.1 to 10.1.1.1-From 10.1.2.1 to 30.1.1.1-From 10.1.2.1 to 40.1.1.1
4
5
DUT-A
2
3
10.1.1.0/24
0.1
0.254
20.1.1.0/30
0.1
0.2
10.1.2.0/24
0.254
0.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.2.0/24-Set Default Route to 10.1.1.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.1.0/24-Set Default Route to 20.1.1.1
Result
1. Write down the configurations of DUT-A and DUT-B for L3 Interfaces
and Static and Default Routes respectively.
2. Show Interface Status of DUT-A and DUT-B
3. Show Routing Tables of DUT-A and DUT-B
4. Attach screenshot of the captured packet

15
ECMP
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA, SMB200 1EA
ez1_38637_0
시안3
Connecting Cables
1
DUT-B
Capture Packet with Ethereal (WireShark)
-Default Gateway: 10.1.1.254
Send Packet-From 10.1.2.1 to 10.1.1.1-From 10.1.2.1 to 30.1.1.1-From 10.1.2.1 to 40.1.1.1
4
5
DUT-A
2
3
10.1.1.0/24
0.1
0.254
20.1.1.0/30
0.1
0.2
10.1.2.0/24
0.254
0.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.2.0/24 using
ECMP-Set Default Route to 10.1.1.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.1.0/24 using
ECMP-Set Default Route to 20.1.1.1
Result
1. Write down the configurations of DUT-A and DUT-B for L3 Interfaces
and ECMP Routes respectively.
2. Show Interface Status of DUT-A and DUT-B
3. Show Routing Tables of DUT-A and DUT-B
4. Attach screenshot of the captured packet
20.1.1.4/30
0.5
0.6

16
Metric (Link Cost)
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA, SMB200 1EA
ez1_38637_0
시안3
Connecting Cables
1
DUT-B
Capture Packet with Ethereal (WireShark)
-Default Gateway: 10.1.1.254
Send Packet-From 10.1.2.1 to 10.1.1.1-From 10.1.2.1 to 30.1.1.1-From 10.1.2.1 to 40.1.1.1
4
5
DUT-A
2
3
10.1.1.0/24
0.1
0.254
20.1.1.0/30
0.1
0.2
10.1.2.0/24
0.254
0.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.2.0/24 applying
different metric-Set Default Route to 10.1.1.1
Configure L3 Interfaces (IP Address)
-Static Route for 10.1.1.0/24 applying
different metric-Set Default Route to 20.1.1.1
Result
1. Write down the configurations of DUT-A and DUT-B for L3 Interfaces
and Routes respectively.
2. Show Interface Status of DUT-A and DUT-B
3. Show Routing Tables of DUT-A and DUT-B
4. Attach screenshot of the captured packet
20.1.1.4/30
0.5
0.6
a3
Cisco Command
ip route 0.0.0.0 0.0.0.0 gateway-address metric

17
Single Area OSPF Network
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA, SMB200 1EA
Result
1. Write down the configurations of DUT-1,2,3 for L3 Interfaces and
OSPF respectively.
2. Show Interface Status of each DUT
3. Show Routing Table of each DUT
4. Show OSPF Neighbor Status of each DUT
5. Attach capture of SMB setup
6. Describe if transmitted traffic is forwarded correctly
DUT-1DUT-2DUT-3Network-C: 172.16.3.0/24.1.1.1SMBPort 1.101 ~ .200SMBPort 3SMBPort 2/30/30/30OSPF Backbone Area.101 ~ .200.101 ~ .200RID: 10.0.0.1 /32RID: 10.0.0.2 /32RID: 10.0.0.3 /32Passive-
interfacePassive-
interfacePassive-
interfaceNetwork-A: 172.16.1.0/24Network-B: 172.16.2.0/24
Send traffic after completing configuration of OSPF network
-SMB1->SMB2: src 172.16.1.101~200, dst 172.16.2.101~200 (bi-direction)
-SMB1->SMB3: src 172.16.1.101~200, dst 172.16.3.101~200 (bi-direction)
-SMB2->SMB3: src 172.16.2.101~200, dst 172.16.3.101~200 (bi-direction)
Challenge
옆구성도에맞게OSPF Routing Network을구성하세요.
#NAME?
#NAME?
-라우터갂링크의주소는알아서구성하되, prefix length는/30 으로함
a3
Cisco Command
configure terminal
interface loopback 0
ip address 10.0.0.1 255.255.255.255
exit
router ospf 100
router-id 10.0.0.1
network x.x.x.x 255.255.255.252 area 0.0.0.0
network 172.16.1.0 255.255.255.0 area 0.0.0.0
passive-interface interface_id

18
Network Convergence with OSPF
Prerequisites
Cisco Router 3500 2EA, UTP Cable (UTP Category-5 Straight) 4EA, PC 1EA, SMB200 1EA
Result
1. Perform traceroute from the PC before link failure
2. Show Interface Status of DUT-1 and DUT-2
3. Show Routing Table of each DUT
4. Show OSPF Neighbor Status of each DUT
5. Disconnect the link between DUT-1 and DUT-2 while sending traffic
from SMB ports.
6. Describe if OSPF convergence occurs correctly after link failure by
looking at SMB traffic counters
7. Repeat 1.~4. to verify OSPF convergence (attach log)
8. Repeat 1.~4. while re-connecting the link between DUT-1 and DUT-2
Challenge
1.While maintaining the previous configuration, change interface
configuration so that a PC can be connected to DUT-1 with IP address
172.16.1.2
2.Disconnect the link between DUT-1 and DUT-2 while sending traffic
from SMB ports.
3.See the changes in OSPF neighbor status and IP routing table on each
DUT.
DUT-1DUT-2DUT-3Network-C: 172.16.3.0/24.1.1.1SMBPort 1.101 ~ .200SMBPort 3SMBPort 2/30/30/30OSPF Backbone Area.101 ~ .200.101 ~ .200RID: 10.0.0.1 /32RID: 10.0.0.2 /32RID: 10.0.0.3 /32Passive-
interfacePassive-
interfacePassive-
interfaceNetwork-A: 172.16.1.0/24Network-B: 172.16.2.0/24.2

19
Appendix.
Introduction to Cisco IOS CLI

20
CLI modes in Cisco IOS
User EXEC mode
Login Prompt
Privileged EXEC mode
Password 입력
“enable”
“configure term”
VLAN Configuration mode
Line Configuration mode
“vlan 2”
“interface FastEthernet 0/1”
“line vty …” or
“line console”
.각interface별설정을하는모드
.각VLAN별설정을하는모드
.Console, TELNET을통한장비에의접속을설정하는모드
.제한된명령어만사용할수있고,
configuration은변경하지못하는모드
.모든명령어를사용할수있으며, configuration
mode로짂입할수있는권한이부여된모드
.Routing process별설정모드
“router ospf 100”
Global Configuration mode
* Type “exit” to return to previous mode
“end” or Ctrl-Z
Interface Configuration mode
Router Configuration mode
“end” or Ctrl-Z
“end” or
Ctrl-Z
“end” or
Ctrl-Z

21
Restore back to factory default
.스위치/라우터장비의이젂Configuration을지우고초기Configuration으로되돌아가기
.“erase startup-config”
.“delete flash:vlan.dat”
.Startup-config만지우면VLAN 설정정보는남아있게됨.
.Cisco 3550/3650의경우, flash file system 내의“vlan.dat” file에VLAN 설정이저장되어있어, 이를지워야함
.“reload” 명령으로재부팅
Switch#
Switch#erase startup-configErasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: completeSwitch#
Switch#
00:43:59: %SYS-7-NV_BLOCK_INIT: Initalized the geometry of nvramSwitch#
Switch#
Switch#delete flash:vlan.datDelete filename [vlan.dat]?
Delete flash:vlan.dat? [confirm]
Switch#
Switch#reloadSystem configuration has been modified. Save? [yes/no]: noProceed with reload? [confirm]y00:47:57: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.

22
Basic L2 switch Configuration
.가장기본적인Single VLAN Ethernet Switch 상태로설정하기
.Disable VTP (“vtp mode transparent”)
.Otherwise, Cisco switches automatically learn VLAN information through trunk port
.Disable CDP (“no cdp run”) & Cisco-protocol nogotiation (“switchport nonegotiate”)
.To prohibit Cisco-proprietary non-standard protocols from being used
.Make all ethernet ports in access mode (participating in the default VLAN as access ports)
.Otherwise, Cisco-proprietary VLAN trunking (e.g. ISL) will be used
.Disable Spanning-tree protocol (to avoid 30-second delay after link-up)
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Switch(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
Switch(config)#
Switch(config)#interface range fa0/1 -24
Switch(config-if-range)#
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport nonegotiate
Switch(config-if-range)#exit
Switch(config)#
Switch(config)#no cdp run
Switch(config)#
Switch(config)#no spanning-tree vlan 1
Switch(config)#
Switch(config)#^Z
Switch#

23
Save Configuration
.“copy running-config startup-config” or
.“write memory”
.현재적용중인Active Configuration = “running-config”
.Flash memory에저장되어있는Configuration = “startup-config”
Switch#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Switch#
Switch#
Switch#
Switch#wr me
Building configuration...
[OK]
Switch#

24
Setting Management IP address
.장비의관리및remote 접속을위한IP address 설정하기
.큰장비는Management 젂용Ethernet port를가지나, 1U 짜리작은장비는따로없음
.우리는VLAN 1 의Switch Vitual Interface에관리용IP주소를설정하기로함
.“interface vlan 1”
.“no shutdown” (interface의default 상태는admin shutdown 상태임)
.“ip address 192.168.10.63 255.255.255.0”
Switch#conf tEnter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Switch(config)#interface vlan 1Switch(config-if)#
Switch(config-if)#no shutdownSwitch(config-if)#
Switch(config-if)#ip address 192.168.10.63 255.255.255.0Switch(config-if)#^ZSwitch#
00:16:42: %SYS-5-CONFIG_I: Configured from console by consoleSwitch#
Switch#ping 192.168.10.1Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/201/1000 msSwitch#

25
Configuring remote TELNET access
.관리자가장비에TELNET을통한remote 접속을할수있도록설정하기
.enable-password 설정(설정안되어있으면TELNET접속허용안됨)
.Login에사용될Username/Password 를설정
.Remote 접속세션설정모드로들어감( “line vty <range of session #> )
.Local User/pwd 정보에의해Login할수있게설정(“login local”)
Switch#conf tEnter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable password ciscoSwitch(config)#
Switch(config)#username cisco password ?
0 Specifies an UNENCRYPTED password will follow7 Specifies a HIDDEN password will followLINE The UNENCRYPTED (cleartext) user passwordSwitch(config)#username ciscopassword ciscoSwitch(config)#
Switch(config)#line vty 0 15Switch(config-line)#
Switch(config-line)#login ?
local Local password checkingtacacs Use tacacs server for password checking<cr>
Switch(config-line)#login localSwitch(config-line)#^ZSwitch#

26
Disabling DNS lookup for typing error
.Cisco CLI에서는아무런명령어없이IP Address나hostname을입력할때의Default behavior가TELNET임
.공교롭게도오타를내게되면hostname인줄알고DNS lookup을시도하느라시갂이걸림
.Default behavior를disable하여오타발생시DNS lookup timeout 시갂을회피
.Console session(“line con 0”)과TELNET session(“line vty 0 15”)에대해각각설정해주어야함
Switch#pign <== typing error
Translating \"pign\"...domain server (255.255.255.255) <== waits for DNS Lookup timeout
% Unknown command or computer name, or unable to find computer address
Switch#
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#line console 0
Switch(config-line)#transport preferred ?
all All protocols
none No protocols
ssh TCP/IP SSH protocol
telnet TCP/IP Telnet protocol
Switch(config-line)#transport preferred none
Switch(config-line)#end
Switch#
00:58:01: %SYS-5-CONFIG_I: Configured from console by console
Switch#
Switch#pign
^
% Invalid input detected at \'^\' marker.
Switch#

27
End of Document
Related Contents
02/15/2012
Netmanias Blog
12/30/2011
Netmanias Blog
12/29/2011
Netmanias Blog
12/28/2011
Netmanias Blog
02/10/2010
Netmanias Technical Documents
11/12/2004
Netmanias Technical Documents
08/11/2003
Netmanias Technical Documents

 

 

     
         
     

 

     
     

넷매니아즈 회원 가입 하기

2019년 1월 현재 넷매니아즈 회원은 49,000+분입니다.

 

넷매니아즈 회원 가입을 하시면,

► 넷매니아즈 신규 컨텐츠 발행 소식 등의 정보를

   이메일 뉴스레터로 발송해드립니다.

► 넷매니아즈의 모든 컨텐츠를 pdf 파일로 다운로드

   받으실 수 있습니다. 

     
     

 

     
         
     

 

 

비밀번호 확인
코멘트 작성시 등록하신 비밀번호를 입력하여주세요.
비밀번호